Site icon RealinfoSec.net

WP-UserOnline Stored Cross-Site Scripting (XSS) PoC – 2.87.6 <=

vulnerability

A Stored XSS Vulnerability was discovered in WordPress plugin, WP-UserOnline, by security researcher Steffin Stanly. With over 20,000 Active Installations, site administrators are urged to update to the latest available version ( 2.88.0 ) which addresses this vulnerability.

Exploit Author: Steffin Stanly
Vendor Homepage: https://github.com/lesterchan/wp-useronline
Software Link: https://wordpress.org/plugins/wp-useronline/
Version: <=2.87.6
Tested on Windows

How to reproduce vulnerability:

  1. Install WordPress 6.0.1 2.
  2. Install and activate WP-UserOnline plugin.
  3. Navigate to Setting >> WP-UserOnline and enter the data into the User(s) Browsing Site.
  4. Add the following payload, and save changes.
 "><script>alert(1)</script> 

On visiting the dashboard, You will observe that the payload successfully got stored in the database and when you are triggering the same functionality in that time JavaScript payload is executing successfully and we are getting a pop-up.

Suggest an edit to this article

Go to Cybersecurity Knowledge Base

Got to the Latest Cybersecurity News

Go to Cybersecurity Academy

Go to Homepage

Stay informed of the latest Cybersecurity trends, threats and developments. Sign up for our Weekly Cybersecurity Newsletter Today.

Remember, CyberSecurity Starts With You!

 2,022 total views,  1 views today

Share the word, let's increase Cybersecurity Awareness as we know it
Exit mobile version